Portal Home > Knowledgebase > Social Engine > HowTo: Fix Album Photo Upload Error 500


HowTo: Fix Album Photo Upload Error 500




  • Dave Safley
    about 15 hours ago - Tues, Oct 26, 2010 at 7:42 AM

    We have not really looked into this further but just to post out the error in our Apache log that we get that sends back an upload error 500 in within the Album Module , seems there may be a ModSecurity issue of sorts:

    Error created:

    [Tue Oct 26 07:33:49 2010] [error] [client 68.4.102.217] mod_security: Access denied with code 403. Error processing request body: Multipart: final boundary missing [severity "EMERGENCY"] [hostname "www.myclearskin.net"] [uri "/albums/upload?ul=1"] [unique_id "TMbmzMwKJzQAABJlKrcAAAAF"]

    [Tue Oct 26 07:33:50 2010] [notice] child pid 4709 exit signal Segmentation fault (11)

    Have a great day!

    Dave
  • SocialEngine Support
    about 9 hours ago - Tues, Oct 26, 2010 at 1:52 PM
    Hello Dave,

    I had a hunch that the problem was being caused by mod_security. Try adding the following rules to the .htaccess file in your SocialEngine root directory:

    1 <IfModule mod_security.c>
    2 SecFilterEngine Off
    3 SecFilterScanPOST Off
    4 </IfModule>
    *** Leave out the numbers / Edit with TextPad or NoteTab Pro / "DO NOT" use windows Note Pad


    Some hosting providers do not allow these options to be overridden in a .htaccess files. If you still receive 500 errors when uploading files, contact your hosting provider and ask them to disable these directives for you.

    Kindest Regards,
    Shaun


Was this answer helpful?

Add to Favourites Add to Favourites    Print this Article Print this Article

Also Read